ಸಂಪದ - Sampada

'ಹೊಸ ಚಿಗುರು, ಹಳೆ ಬೇರು'

ಉಬಂಟು ಫಿಸ್ಟಿಯಲ್ಲಿ ಕನ್ನಡ (kannada in ubuntu feisty)

May 6, 2007 - 3:34am
omshivaprakash
1

ಉಬಂಟು ಫಿಸ್ಟಿಯಲ್ಲಿ  (ubuntu feisty) ಕನ್ನಡ ಉಪಯೊಗಿಸಬೇಕೇ?

Are you trying to view kannada pages in ubuntu feisty (7.0.4)? You will end up seeing lots of junk characters for sure. Here I write a small how to which is a continuation of hpn's other two documentations available in following links :

 http://dev.sampada.net/wiki/Kannada-on-Ubuntu-Edgy

 http://dev.sampada.net/wiki/Kannada-on-Ubuntu-Edgy

 And also the ubuntu documentation on SCIM tool

 https://wiki.ubuntu.com/InputMethods/SCIM/Setup

Following the same instructions help you to resolve the font rendering issues in firefox on ubuntu feisty.

So, I need not repeat the same steps to fix the issue here again. But I want to report what I did to enable SCIM as default input method for your operating system. This allows you to type in kannada on any application.

 You might have got the following symbolic link instruction from above links but, default input method won't show up SCIM tool at the startup.

  ln -s /etc/X11/xinit/xinput.d/scim ~/.xinput.d/default

 Work around:

Goto System menu :-> Administration  :-> Language support 

Here, Select "Enable support for complex characters"  and click on Ok as given in the following image. 

Default input method 

This step installs required dependencies (don't forget to keep the cd in your drive or atleast keep your system connected to internet)

 Once this is done, the symbolic link which we created earlier will start working fine after a system restart. Change the language to kannda and start typing on your favorite gaim, kopete konversation or anything 

  Note: You can change the language by clicking on SCIM icon which will be displayed on your desktop,  using (<ctrl> + <space bar>) buttons in the keyboard.

Hpn, special thanks for fixing the fonts issue. I was bit ignorant about the fixes reported in the above link. 

‍ನಿಮಗೆ ಈ ಬರಹ ಇಷ್ಟವಾಯಿತೇ? ತಿಳಿಸಿ: 
To prevent automated spam submissions leave this field empty.

Submitted by smurthygr on

ಎಲ್ಲಾ ಮಾಡಿ ನೋಡಿದೆ, ಕನ್ನಡ ಮಾತ್ರ ಬರ್ತಾ ಇಲ್ಲ! ನಾನು KDE ಬಳಸ್ತೇನೆ. ಅದರಲ್ಲಿ skim ಹಾಕಿ ಕಷ್ಟ ಪಟ್ಟೆ. ಬಹುಶಃ ಏನೋ ಸಣ್ಣ ತಪ್ಪು ಆಗಿರಬಹುದು. konqueror ನಲ್ಲಿ ಕನ್ನಡ ಕಾಣುತ್ತೆ. firefoxನಲ್ಲಿ ಇಲ್ಲ. ಕನ್ನಡ ಟೈಪ್ ಮಾಡಲೂ ಆಗಲ್ಲ. ಮರಳಿ ಯತ್ನವ ಮಾಡಿ ನೋಡೋಣ. ಇದನ್ನು ವಿಂಡೋಸ್‌ನಲ್ಲೇ ಬರೆಯಬೇಕಾಗಿದೆ.

Submitted by ASHOKKUMAR on

ಪ್ರತಿಕ್ರಿಯೆಯಲ್ಲಿ ಚಿತ್ರದ ಲಿಂಕ್ ಕೊಡಬಹುದು. ಚಿತ್ರ ಕೊಡೋದು ಸಾಧ್ಯವಿಲ್ಲ. ಪ್ರತ್ಯೇಕ ಬರಹ ಪ್ರಕಟಿಸಿದಾಗ rich text enable ಕ್ಲಿಕ್ಕಿಸಿ, ಅಲ್ಲಿ ಚಿತ್ರ ಸೇರಿಸುವ ಸೌಲಭ್ಯ ಇದೆ.
*ಅಶೋಕ್

Submitted by omshivaprakash on

smurthygr ಅವರೆ,

Kannada-on-Ubuntu-Edgy ಈ ಕೊಂಡಿಯಲ್ಲಿರುವ ಎಲ್ಲ ಸೂಚನೆಗಳನ್ನ ಪ್ರಯೊಗಿಸಿದ್ದೀರೆಂದು ಬಾವಿಸಿದ್ದೇನೆ.

firefox ಬೈನರಿ ಯಲ್ಲಿ ಕೆಳಕಂಡ ಬದಲಾವಣೆ ಮಾಡಿ ನೊಡಿ:

firefox ಬೈನರಿ ಹುಡುಕಲು :

$which firefox

ನಂತರ vi ಎಡಿಟರ್ ನಲ್ಲಿ MOZ_DISABLE_PANGO ಹುಡುಕಿ :

MOZ_DISABLE_PANGO ಮೌಲ್ಯವನ್ನ ಸೊನ್ನೆಗೆ ಕೆಳಗೆ ತೊರಿಸಿರುವ ಹಾಗೆ ಬದಲಿಸಿ

[quote]
if [ "x${MOZ_DISABLE_PANGO}" = x ]; then
if egrep '^(bn|gu|hi|kn|en|en_US|en_IN|ml|mr|ne|pa|si|ta|te)_' \
/var/lib/locales/supported.d/*[^~] >/dev/null 2>&1; then
MOZ_DISABLE_PANGO=0
else
MOZ_DISABLE_PANGO=0
fi
export MOZ_DISABLE_PANGO
fi
[quote]

ಇದಾದ ನಂತರ firefox ಮರುಚಾಲನೆ ಮಾಡಿ.

ಟ್ವಿಟ್ಟರಿನಲ್ಲಿ ಸಂಪದ